Aspect (Create Change Request)

From wiki.eclass.eu
Jump to: navigation, search

The following changes are possible for an Aspect:

  1. Browse
  2. Change Text
  3. Create Aspect
  4. Remove Aspect
  5. Reactivate
  6. Assign Block Reference
  7. Withdraw Block Reference
  8. Assign Property
  9. Withdraw Property
  10. Reactivate Deprecated Property
  11. Aspect Types

Contents

[edit] Aspects

The function Aspects offers users the possibility to administer available Aspects and create change requests for new ones.

This function is available under [User – Change Request].

[edit] Browse

Select menu entry [List of Aspects]. All Aspects available in the system, as well as all existing Change Requests for Aspects, will be displayed as list.

AS1.png

Figure 1: List of All Available Aspects and All CRs Related to Aspects


In this list, users have the possibility to:

Search after specific Aspects or CRs


Aspects2.png

Figure 2: Simple Search


Aspects3.png

Figure 3: Advanced Search


Filter Aspects by Change Processed

Aspects4.png

Figure 4: Check Box for Filter Function


Select the language in which Aspects are displayed

AS5.png

Figure 5: Combo Box for Selecting the Content Language


Export certain aspects:

  1. press Export
  2. under Tab “Data Source”, users may select:
  • the Export range: whether to export all Aspects or a previously marked selection
  • the Export type: DIN 4002
  • the option of having the results sent by e-mail or not

AS6.png

Figure 6: Tab “Data Source” Related to Export

  1. under Tab “Selection of attributes”, users may select:
  • the desired attributes of Aspects to be exported
  • the export languages

AS7.png

Figure 7: Tab “Selection of attributes” Related to Export

[edit] Change Text

Select menu entry [Change Textual Information]. The system will display the list of all available Aspects as well as change requests.

In this list, users have the possibility to change the content language (in which Aspects will be displayed) and search after specific Aspects (structure elements or change requests).

AS8.png

Figure 8: List of All Available Aspects and CRs Related to Aspects

Select an Aspect in the list by clicking it in order to create a CR for changing the textual information. The Change Textual Information dialog will open:

AS9.png

Figure 9: Change Textual Information Dialog


Fill in the fields with the new text and then press button “Save”.

Attention: The fields Preferred Name and Reason are mandatory fields!!!

System displays message: Change request saved. The new created change requests will be displayed under My Change Request.

[edit] Create Aspect

Select menu entry [Create Aspect]. The system will display the list of all available Aspects as well as change requests for New Aspects.

In this list, users have the possibility to change the content language (in which Aspects will be displayed) and search after specific Aspects (structure elements or change requests).

At the same time, two buttons are displayed: “Create Aspect” and “Create Aspect directly assigned to Application Class”.

AS10.png

Figure 10: List of All Available Aspects and CRs for New Aspects


Create Aspect

When pressing the button “Create Aspect”, the system will display the Create Aspect dialog.

Aspects11.png

Figure 11: Dialog for Create Aspect


Fill in the fields, select aspect type and press button “Save”. The New Aspect will be created independently, meaning not assigned to an AC.

Attention: The fields Preferred Name, Aspect type and Reason are mandatory fields!!!

Create Aspect directly assigned to Application Class

When pressing the button “Create Aspect directly assigned to Application Class”, the system will display the hierarchical structure of elements.

AS12.png

Figure 12: Hierarchical Structure of Elements

Mark the Application Class to which the Aspect will be assigned and press button Select (this button will be active only after an AC has been marked within the hierarchy). The system displays the Create Aspect dialog.

Aspects13.png

Figure 13: Dialog for Create Aspect Directly Assigned to Application Class

Observation: If the user changes his mind and decides to create the Aspect independently (not assigned to the selected AC), he can do so by pressing button “Clear”, without having to go back to the “Create Aspect” function.

Fill in the fields, select aspect type and press button “Save”.

Attention: The fields Preferred Name, Aspect type and Reason are mandatory fields!!!

* According to requirements, the new created aspect can be assigned to one or more Application Classes under menu entry “Application Class”, function “Assign Aspect”.

[edit] Remove Aspect

According to decision of CRD, function is inactive.

Select menu entry [Remove Aspect]. The system displays a list containing all available aspects.

In this list, users have the possibility to change the content language (in which Aspects will be displayed) and search after specific Aspects (structure elements or change requests).

AS14.png

Figure 14: List of All Available Aspects


User selects an Aspect from the list – the system displays the Remove Aspect dialog:

Aspects15.png

Figure 15: Remove Aspect Dialog

Under the tab “Cross-References”, all instances where the Aspect is used are displayed, so that the user can evaluate the impact the operation “Remove Aspect” will have on the system.

Fill in the mandatory field “Reason*” and press save -> the CR for Removing the Aspect will be saved and can be viewed under “My Change Requests” or “List of Aspects”.

[edit] Reactivate

[edit] Assign Block Reference

Select menu entry [Assign Reference of Block]. All Aspects available in the system, as well as all existing Change Requests for new Aspects, will be displayed as list. In this list, users have the possibility to change the content language (in which Aspects will be displayed) and search after specific Aspects (structure elements or change requests).

AS16.png

Figure 16: List of Aspects and List of Change Requests for New Aspects

Select one Aspect (SE or CR) in the list by clicking it.

In the next dialog, all Reference Properties available in the system, as well as all existing Change Requests for new Reference Properties, will be displayed as list. In this list, users have the possibility to change the content language (in which Reference Properties will be displayed) and search after specific Reference Properties (structure elements or change requests).

* No Blocks and Reference Properties SE are available in the eCl@ss Portal.

To proceed, use one of the following approaches:

1. Select the Reference Property/Properties (structure elements or change requests) to be assigned to the Aspect by checking the box in front of it/them and press button “Select”.

AS17.png

Figure 17: List of Reference Properties (empty for now, as there are no SE Blocks and Reference Properties in eCl@ss) and List of Change Requests for New Properties

2. If several Reference Properties and/or Change Requests for New Reference Properties are to be assigned to the Aspect:

Select the Reference Properties (structure elements) to be assigned to the Aspect by checking the box in front of them and press button “Add to collection”. For structure elements, this button is located above the list of SE-Reference Properties.

Select the Change Requests for New Reference Properties to be assigned to the Aspect by checking the box in front of them and press button “Add to collection”. For change requests, the button is located under the header “Change Requests”.

AS18.png

Figure 18: Button Add to Collection for Reference Properties (SE) and Button Add to Collection for Change Requests

*By adding Reference Properties SE or CR to collection, user will have an overview of all Reference Properties (SE or CR) to be assigned to the Aspect under “Collection of assignments”.

Aspects19.png

Figure 19: Collection of Assignments

Reference Properties (SE or CR) can be removed from the Collection of assignments by pressing button “Remove selection” (only marked Reference Properties SE and CR will be removed) or “Remove all” (all Reference Properties SE or CR will be removed from the collection of assignments).

As next step, press button “Select”.

System opens the “Add existing property” dialog.


*By pressing Remove, the respective Reference Property SE or CR will be removed.

*By pressing Select, user can select another Aspect to which Reference Properties will be assigned /other Reference Properties to be assigned to the Aspect.


Fill in the field “Reason*” and press Save.


AS20.png

Figure 20: Add Existing Property Dialog


System displays message: Change request saved. The new created change requests will be displayed under My Change Request.


AS21.png

Figure 21: Change Request Saved

[edit] Withdraw Block Reference

According to decision of CRD, function is inactive.

Select menu entry [Withdraw Reference of Block]. System displays the hierarchical structure of elements.

AS22.1.png

Figure 22: Hierarchical Structure of Elements


Select the reference property you want to withdraw from the aspect and press button „Select“.

AS23.png

Figure 23: Select Reference Property to be Withdrawn from the Aspect


System opens the „Withdraw Property“ Dialog. Fill in the field “Reason*” and press Save.


AS24.png

Figure 24: Withdraw Property Dialog


System displays message: Change request saved. The new created change requests will be displayed under My Change Request.


AS25.1.png

Figure 25: Change Request Saved

[edit] Assign Property

Select menu entry [Assign Property]. All Aspects available in the system, as well as all existing Change Requests for new Aspects, will be displayed as list. In this list, users have the possibility to change the content language (in which Aspects will be displayed) and search after specific Aspects (structure elements or change requests).

AS26.png

Figure 26: List of Aspects and List of Change Requests for New Aspects

Select one Aspect (SE or CR) in the list by clicking it.

In the next dialog, all Properties available in the system, as well as all existing Change Requests for new Properties, will be displayed as list. In this list, users have the possibility to change the content language (in which Properties will be displayed) and search after specific Property (structure elements or change requests).

To proceed, use one of the following approaches:

1. Select the Property/Properties (structure elements or change requests) to be assigned to the Aspect by checking the box in front of it/them and press button “Select”.

AS27.png

Figure 27: List of Properties and List of Change Requests for New Properties

2. If several Properties and/or Change Requests for New Properties are to be assigned to the Aspect:

Select the Properties (structure elements) to be assigned to the Aspect by checking the box in front of them and press button “Add to collection”. For structure elements, this button is located above the list of SE-Properties.

Select the Change Requests for New Properties to be assigned to the Aspect by checking the box in front of them and press button “Add to collection”. For change requests, the button is located under the header “Change Requests”.

Aspects28.png

Figure 28: Button Add to Collection for Properties (SE) and Button Add to Collection for Change Requests


*By adding Properties SE or CR to collection, user will have an overview of all Properties (SE or CR) to be assigned to the Aspect under “Collection of assignments”.

Aspects29.png

Figure 29: Collection of Assignments

Properties (SE or CR) can be removed from the Collection of assignments by pressing button “Remove selection” (only marked Properties SE and CR will be removed) or “Remove all” (all Properties SE or CR will be removed from the collection of assignments).

As next step, press button “Select”.

System opens the “Add existing property” dialog.


*By pressing Remove, the respective Property SE or CR will be removed.

*By pressing Select, user can select another Aspect to which Properties will be assigned / other Properties to be assigned to the Aspect.


Fill in the field “Reason*” and press Save.


Aspects30.png

Figure 30: Add Existing Property Dialog


System displays message: Change request saved. The new created change requests will be displayed under My Change Request.


AS31.png

Figure 31: Change Request Saved


[edit] Withdraw Property

According to decision of CRD, function is inactive.

Select menu entry [Withdraw Property]. System displays the hierarchical structure of elements.

AS32.1.png

Figure 32: Hierarchical Structure of Elements


Select the property you want to withdraw from the aspect and press button „Select“.

AS33.png

Figure 33: Select Property to be Withdrawn from Aspect


System opens the „Withdraw Property“ Dialog. Fill in the field “Reason*” and press Save.

AS34.png

Figure 34: Withdraw Property Dialog


System displays message: Change request saved. The new created change requests will be displayed under My Change Request.

AS35.1.png

Figure 35: Change Request Saved


[edit] Reactivate Deprecated Property

[edit] Aspect Types

Aspect Types can be managed only by users assigned to role “Office”.

Under “Office”, select menu entry “Manage Aspect Types”.

System displays the “Manage Aspect Types” Dialog.

AS42.png

Figure 42: Manage Aspect Types Dialog


In this dialog, user can:

1. Create new Aspect Types

2. Edit existing Aspect Types

3. Withdraw existing Aspect Types


1. Create New Aspect Type

To create a new Aspect Type, press „Create Aspect Type“.

AS43.1.png

Figure 43: Create Aspect Type


System opens the „Create Aspect Type“-Dialog.

A44.png

Figure 44: Create Aspect Type Dialog

Select the languages in which you want to create the new Aspect Type from the combo-box „Content language“. English is the default language.

A45.png

Figure 45: Combo-Box „Content Language“

Fill in the fields and press button Save.

Attention: Preferred name* is a mandatory field!!!

AS46.png

Figure 46: Save the New Created Aspect Type

System will display the message „Aspect type saved“. The new created Aspect Type will be displayed in the list of available Aspect Types.

AS47.png

Figure 47: List of Available Aspect Types


2. Edit Existing Aspect Type

All existing Aspect Types are displayed in the list of Aspect Types.

Aspect Types may be used or not used in Application Classes.

For Aspect Types which are used in Application Classes, the value „True“ will be displayed in column „Used?“.

For Aspect Types which are not used in Application Classes, the value „False“ will be displayed in column „Used?“.

2.1 EDIT-Function in case of Unused Aspect Types

Aspects48.png

Figure 48: Unused Aspect Type


Select Edit. System displays the Edit Aspect Type Dialog.

Select the languages in which changes are to be done, edit the content and press save.

A49.png

Figure 49: Edit Aspect Type Dialog (Unused Aspect Type)

System displays the message „Aspect type updated“. The updated Aspect Type will be displayed in the list of existing Aspect Types.

Aspects50.png

Figure 50: Aspect Type Updated

2.2 EDIT-Function in Case of Used Aspect

Select Edit. System displays the Edit Aspect Type Dialog.

Select the languages in which changes are to be done, edit the content and press save.

A51.png

Figure 51: Edit Aspect Type (Used Aspect Type)

System displays the message „Aspect type is used and cannot be updated directly. A new aspect type was created instead.“

The Aspect Type created by editing the used Aspect Type will be displayed in the list of existing Aspect Types with the value „False“ (unused).

AS52.png

Figure 52: New Created Aspect Type in the List of Aspect Types

3. Withdraw Existing Aspect Type

*Withdraw of aspect type is possible only if aspect type is not used by any aspect (SE or CR). If aspect type was already released (part of current release) it will be marked as “deleted” in next release, and it will remain in the database as part of current and older releases. If aspect type was not released yet and it is not used by a CR, delete is allowed and this will permanently delete the aspect type.

All existing Aspect Types are displayed in the list of Aspect Types.

Aspect Types may be used or not used in Application Classes.

For Aspect Types which are used in Application Classes, the value „True“ will be displayed in column „Used?“.

For Aspect Types which are not used in Application Classes, the value „False“ will be displayed in column „Used?“.

3.1 Withdraw Unused Aspect Type

Select Withdraw. System displays the “Withdraw Aspect Type” Dialog.

Replace53.png

Figure 53: Withdraw Aspect Type Dialog (Unused Aspect Type)

If you are certain that you want to withdraw the Aspect Type, press button „Save“. The Aspect Type will be removed from the list of existing Aspect Types.

3.2 Withdraw Used Aspect Type

Select Withdraw. System displays the “Withdraw Aspect Type” Dialog.

Replace53.png

Figure 54: Withdraw Aspect Type Dialog (Used Aspect Type)

If you are certain that you want to withdraw the Aspect Type, press button „Save“. The system displays the message: „Aspect type withdrawn (marked for delete in next version).“

AS55.png

Figure 55: Aspect Type Marked for Delete in Next Version

This action can be revoked by simply pressing „Revoke withdraw“.


[edit] Related Change Requests

Personal tools